The external water pump on my Astoria SAE is running constantly. I didn't notice this before, I don't think I've heard it before even when I've emptied the tank making a jug of tea. The machine is on 24/7, is there something that is supposed to cycle the pump motor as necessary? Water pressure is good, machine seems to be functioning well. HELP!!!

Views: 236

Reply to This

Replies to This Discussion

Relay for the pump is stuck closed.
Thank you, can you tell me were to find the relay? Is it as simple as changing a head light relay in a car?

It's probably soldered to the CPU/Brain.  Which specific model do you have?  What year is it?  How many groups?

Stephen Robert Thomas said:

Thank you, can you tell me were to find the relay? Is it as simple as changing a head light relay in a car?
Thank you for your reply. I ended up calling out twp techs to fix my espresso machine. First said it was unrepairable, the second condemned the CPU, a new CPU did not work and would not activate the pump at all. He put my old CPU back in while condemning the machine. It's worked perfectly since!!! Best guess loose connection to the CPU that was inadvertently repaired. It was quite a ride! Again thanks

Glad you got it fixed!

Reply to Discussion

RSS

Barista Exchange Partners

Barista Exchange Friends

Keep Barista Exchange Free

Are you enjoying Barista Exchange? Is it helping you promote your business and helping you network in this great industry? Donate today to keep it free to all members. Supporters can join the "Supporters Group" with a donation. Thanks!

Clicky Web Analytics

© 2020   Created by Matt Milletto.   Powered by

Badges  |  Report an Issue  |  Terms of Service